Arbitrary Code Injection Affecting otrs2 package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.49% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-OTRS2-344011
  • published21 Nov 2017
  • disclosed21 Nov 2017

Introduced: 21 Nov 2017

CVE-2017-16664  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:16.04 otrs2.

NVD Description

Note: Versions mentioned in the description apply only to the upstream otrs2 package and not the otrs2 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Code injection exists in Kernel/System/Spelling.pm in Open Ticket Request System (OTRS) 5 before 5.0.24, 4 before 4.0.26, and 3.3 before 3.3.20. In the agent interface, an authenticated remote attacker can execute shell commands as the webserver user via URL manipulation.