Improper Authorization Affecting pacemaker package, versions <1.1.14-2ubuntu1.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.4% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PACEMAKER-317080
  • published27 Jun 2018
  • disclosed10 Sept 2018

Introduced: 27 Jun 2018

CVE-2016-7035  (opens in a new tab)
CWE-285  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 pacemaker to version 1.1.14-2ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

An authorization flaw was found in Pacemaker before 1.1.16, where it did not properly guard its IPC interface. An attacker with an unprivileged account on a Pacemaker node could use this flaw to, for example, force the Local Resource Manager daemon to execute a script as root and thereby gain root access on the machine.