Improper Authentication Affecting pacemaker package, versions <1.1.14-2ubuntu1.6


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PACEMAKER-344112
  • published18 Apr 2019
  • disclosed18 Apr 2019

Introduced: 18 Apr 2019

CVE-2018-16877  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 pacemaker to version 1.1.14-2ubuntu1.6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pacemaker package and not the pacemaker package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A flaw was found in the way pacemaker's client-server authentication was implemented in versions up to and including 2.0.0. A local attacker could use this flaw, and combine it with other IPC weaknesses, to achieve local privilege escalation.

CVSS Base Scores

version 3.1