Use After Free Affecting pcsc-lite package, versions <1.8.14-1ubuntu1.16.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.04% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PCSCLITE-324816
  • published23 Feb 2017
  • disclosed23 Feb 2017

Introduced: 23 Feb 2017

CVE-2016-10109  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 pcsc-lite to version 1.8.14-1ubuntu1.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pcsc-lite package and not the pcsc-lite package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Use-after-free vulnerability in pcsc-lite before 1.8.20 allows a remote attackers to cause denial of service (crash) via a command that uses "cardsList" after the handle has been released through the SCardReleaseContext function.