Arbitrary Code Injection Affecting php-nette package, versions <2.3.8-1ubuntu1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
34.42% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PHPNETTE-1048212
  • published4 Dec 2020
  • disclosed1 Oct 2020

Introduced: 1 Oct 2020

CVE-2020-15227  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 php-nette to version 2.3.8-1ubuntu1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-nette package and not the php-nette package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Nette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.

CVSS Base Scores

version 3.1