Memory Leak Affecting privoxy package, versions <3.0.24-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.9% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PRIVOXY-1086076
  • published16 Mar 2021
  • disclosed25 May 2021

Introduced: 16 Mar 2021

CVE-2021-20209  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 privoxy to version 3.0.24-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A memory leak vulnerability was found in Privoxy before 3.0.29 in the show-status CGI handler when no action files are configured.

CVSS Base Scores

version 3.1