Deserialization of Untrusted Data Affecting puppet package, versions <3.8.5-2ubuntu0.1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.76% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PUPPET-364879
  • published5 Jul 2017
  • disclosed5 Jul 2017

Introduced: 5 Jul 2017

CVE-2017-2295  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 puppet to version 3.8.5-2ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puppet package and not the puppet package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format. This could be used to force YAML deserialization in an unsafe manner, which would lead to remote code execution. This change constrains the format of data on the wire to PSON or safely decoded YAML.