XML External Entity (XXE) Injection Affecting python-pysaml2 package, versions <3.0.0-3ubuntu1.16.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.02% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-PYTHONPYSAML2-308631
  • published24 Mar 2017
  • disclosed24 Mar 2017

Introduced: 24 Mar 2017

CVE-2016-10149  (opens in a new tab)
CWE-611  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 python-pysaml2 to version 3.0.0-3ubuntu1.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-pysaml2 package and not the python-pysaml2 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

XML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote attackers to read arbitrary files via a crafted SAML XML request or response.