Uncontrolled Recursion Affecting qpdf package, versions <8.0.2-3~16.04.1+esm1


Severity

Recommended
0.0
low
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.21% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-QPDF-1190221
  • published28 Jul 2021
  • disclosed6 Oct 2018

Introduced: 6 Oct 2018

CVE-2018-18020  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 qpdf to version 8.0.2-3~16.04.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpdf package and not the qpdf package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.