Out-of-bounds Write Affecting qpdf package, versions <8.0.2-3~16.04.1+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.27% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-QPDF-1535804
  • published27 Jul 2021
  • disclosed20 Jul 2021

Introduced: 20 Jul 2021

CVE-2021-36978  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 qpdf to version 8.0.2-3~16.04.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpdf package and not the qpdf package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

QPDF 9.x through 9.1.1 and 10.x through 10.0.4 has a heap-based buffer overflow in Pl_ASCII85Decoder::write (called from Pl_AES_PDF::flush and Pl_AES_PDF::finish) when a certain downstream write fails.

CVSS Base Scores

version 3.1