Improper Input Validation Affecting qpdf package, versions <8.0.2-3~16.04.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.8% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-QPDF-319532
  • published27 Aug 2017
  • disclosed27 Aug 2017

Introduced: 27 Aug 2017

CVE-2017-12595  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 qpdf to version 8.0.2-3~16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qpdf package and not the qpdf package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The tokenizer in QPDF 6.0.0 and 7.0.b1 is recursive for arrays and dictionaries, which allows remote attackers to cause a denial of service (stack consumption and segmentation fault) or possibly have unspecified other impact via a PDF document with a deep data structure, as demonstrated by a crash in QPDFObjectHandle::parseInternal in libqpdf/QPDFObjectHandle.cc.