OS Command Injection Affecting rake package, versions <10.5.0-2ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.36% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RAKE-559130
  • published26 Feb 2020
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2020-8130  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 rake to version 10.5.0-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rake package and not the rake package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character |.

CVSS Base Scores

version 3.1