Insufficient Verification of Data Authenticity Affecting rpm package, versions <4.12.0.1+dfsg1-3ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.77% (55th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RPM-1086143
  • published16 Mar 2021
  • disclosed26 Mar 2021

Introduced: 16 Mar 2021

CVE-2021-20271  (opens in a new tab)
CWE-345  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 rpm to version 4.12.0.1+dfsg1-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm package and not the rpm package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A flaw was found in RPM's signature check functionality when reading a package file. This flaw allows an attacker who can convince a victim to install a seemingly verifiable package, whose signature header was modified, to cause RPM database corruption and execute code. The highest threat from this vulnerability is to data integrity, confidentiality, and system availability.

CVSS Base Scores

version 3.1