Improper Input Validation Affecting rssh package, versions <2.3.4-4+deb8u2ubuntu0.16.04.2


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
4.87% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RSSH-336578
  • published3 Feb 2019
  • disclosed6 Feb 2019

Introduced: 3 Feb 2019

CVE-2019-3463  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 rssh to version 2.3.4-4+deb8u2ubuntu0.16.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rssh package and not the rssh package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Insufficient sanitization of arguments passed to rsync can bypass the restrictions imposed by rssh, a restricted shell that should restrict users to perform only rsync operations, resulting in the execution of arbitrary shell commands.

CVSS Base Scores

version 3.1