CRLF Injection Affecting ruby2.3 package, versions <2.3.1-2~16.04.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.69% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBY23-308589
  • published12 Jun 2017
  • disclosed12 Jun 2017

Introduced: 12 Jun 2017

CVE-2015-9096  (opens in a new tab)
CWE-93  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ruby2.3 to version 2.3.1-2~16.04.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.3 package and not the ruby2.3 package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Net::SMTP in Ruby before 2.4.0 is vulnerable to SMTP command injection via CRLF sequences in a RCPT TO or MAIL FROM command, as demonstrated by CRLF sequences immediately before and after a DATA substring.