Cross-site Scripting (XSS) Affecting ruby-loofah package, versions <2.0.3-2+deb9u3build0.16.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.56% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBYLOOFAH-674589
  • published10 Sept 2020
  • disclosed22 Oct 2019

Introduced: 22 Oct 2019

CVE-2019-15587  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ruby-loofah to version 2.0.3-2+deb9u3build0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-loofah package and not the ruby-loofah package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

In the Loofah gem for Ruby through v2.3.0 unsanitized JavaScript may occur in sanitized output when a crafted SVG element is republished.

CVSS Base Scores

version 3.1