Inefficient Regular Expression Complexity Affecting ruby-nokogiri package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.52% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBYNOKOGIRI-2767561
  • published1 Jun 2025
  • disclosed11 Apr 2022

Introduced: 11 Apr 2022

CVE-2022-24836  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:16.04 ruby-nokogiri.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-nokogiri package and not the ruby-nokogiri package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri < v1.13.4 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri >= 1.13.4. There are no known workarounds for this issue.

CVSS Base Scores

version 3.1