Directory Traversal Affecting ruby-rack package, versions <1.6.4-3ubuntu0.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.36% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBYRACK-1128837
  • published1 Oct 2020
  • disclosed2 Jul 2020

Introduced: 2 Jul 2020

CVE-2020-8161  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ruby-rack to version 1.6.4-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosure.

CVSS Base Scores

version 3.1