Inefficient Regular Expression Complexity Affecting ruby-rack package, versions <1.6.4-3ubuntu0.2+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.23% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBYRACK-3167510
  • published19 Aug 2025
  • disclosed5 Dec 2022

Introduced: 5 Dec 2022

CVE-2022-30122  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ruby-rack to version 1.6.4-3ubuntu0.2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.

CVSS Base Scores

version 3.1