Directory Traversal Affecting ruby-rack-cors package, versions <0.4.0-1+deb9u2build0.16.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.46% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBYRACKCORS-534632
  • published15 Nov 2019
  • disclosed14 Nov 2019

Introduced: 14 Nov 2019

CVE-2019-18978  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ruby-rack-cors to version 0.4.0-1+deb9u2build0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack-cors package and not the ruby-rack-cors package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

An issue was discovered in the rack-cors (aka Rack CORS Middleware) gem before 1.0.4 for Ruby. It allows ../ directory traversal to access private resources because resource matching does not ensure that pathnames are in a canonical format.

CVSS Base Scores

version 3.1