XML Injection Affecting ruby-saml package, versions <1.1.2-1ubuntu1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.21% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-RUBYSAML-274039
  • published23 Jan 2017
  • disclosed23 Jan 2017

Introduced: 23 Jan 2017

CVE-2016-5697  (opens in a new tab)
CWE-91  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ruby-saml to version 1.1.2-1ubuntu1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-saml package and not the ruby-saml package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.