OS Command Injection Affecting sa-exim package, versions <4.2.1-14+deb8u1build0.16.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.25% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SAEXIM-674628
  • published10 Sept 2020
  • disclosed22 Dec 2019

Introduced: 22 Dec 2019

CVE-2019-19920  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 sa-exim to version 4.2.1-14+deb8u1build0.16.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sa-exim package and not the sa-exim package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

CVSS Base Scores

version 3.1