Information Exposure Affecting sane-backends package, versions <1.0.25+git20150528-1ubuntu2.16.04.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.96% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SANEBACKENDS-346675
  • published20 Mar 2017
  • disclosed20 Mar 2017

Introduced: 20 Mar 2017

CVE-2017-6318  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 sane-backends to version 1.0.25+git20150528-1ubuntu2.16.04.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sane-backends package and not the sane-backends package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

saned in sane-backends 1.0.25 allows remote attackers to obtain sensitive memory information via a crafted SANE_NET_CONTROL_OPTION packet.