Information Exposure Affecting simplesamlphp package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.46% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SIMPLESAMLPHP-340166
  • published1 Sept 2017
  • disclosed1 Sept 2017

Introduced: 1 Sep 2017

CVE-2017-12872  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:16.04 simplesamlphp.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The (1) Htpasswd authentication source in the authcrypt module and (2) SimpleSAML_Session class in SimpleSAMLphp 1.14.11 and earlier allow remote attackers to conduct timing side-channel attacks by leveraging use of the standard comparison operator to compare secret material against user input.