CVE-2020-15709 Affecting software-properties package, versions <0.96.20.10


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.33% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SOFTWAREPROPERTIES-597563
  • published6 Aug 2020
  • disclosed5 Sept 2020

Introduced: 6 Aug 2020

CVE-2020-15709  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 software-properties to version 0.96.20.10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream software-properties package and not the software-properties package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Versions of add-apt-repository before 0.98.9.2, 0.96.24.32.14, 0.96.20.10, and 0.92.37.8ubuntu0.1~esm1, printed a PPA (personal package archive) description to the terminal as-is, which allowed PPA owners to provide ANSI terminal escapes to modify terminal contents in unexpected ways.

CVSS Base Scores

version 3.1