Insufficient Comparison Affecting sox package, versions <14.4.1-5+deb8u4ubuntu0.1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.11% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SOX-12008998
  • published19 Aug 2025
  • disclosed25 May 2022

Introduced: 25 May 2022

CVE-2022-31650  (opens in a new tab)
CWE-697  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 sox to version 14.4.1-5+deb8u4ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sox package and not the sox package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

In SoX 14.4.2, there is a floating-point exception in lsx_aiffstartwrite in aiff.c in libsox.a.

CVSS Base Scores

version 3.1