Heap-based Buffer Overflow Affecting sox package, versions <14.4.1-5+deb8u4ubuntu0.1+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.05% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SOX-2433500
  • published1 Jun 2025
  • disclosed14 Apr 2022

Introduced: 14 Apr 2022

CVE-2021-40426  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 sox to version 14.4.1-5+deb8u4ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sox package and not the sox package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A heap-based buffer overflow vulnerability exists in the sphere.c start_read() functionality of Sound Exchange libsox 14.4.2 and master commit 42b3557e. A specially-crafted file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

CVSS Base Scores

version 3.1