Out-of-Bounds Affecting sox package, versions <14.4.1-5ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
7.71% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SOX-292321
  • published31 Dec 2014
  • disclosed31 Dec 2014

Introduced: 31 Dec 2014

CVE-2014-8145  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 sox to version 14.4.1-5ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sox package and not the sox package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Multiple heap-based buffer overflows in Sound eXchange (SoX) 14.4.1 and earlier allow remote attackers to have unspecified impact via a crafted WAV file to the (1) start_read or (2) AdpcmReadBlock function.

CVSS Base Scores

version 3.1