Buffer Overflow Affecting sox package, versions <14.4.1-5+deb8u4ubuntu0.1+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.48% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SOX-2993994
  • published12 Jul 2025
  • disclosed25 Aug 2022

Introduced: 25 Aug 2022

CVE-2021-23159  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 sox to version 14.4.1-5+deb8u4ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sox package and not the sox package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A vulnerability was found in SoX, where a heap-buffer-overflow occurs in function lsx_read_w_buf() in formats_i.c file. The vulnerability is exploitable with a crafted file, that could cause an application to crash.

CVSS Base Scores

version 3.1