Improper Input Validation Affecting spice-protocol package, versions <0.12.10-1ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.93% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-SPICEPROTOCOL-266450
  • published22 Aug 2018
  • disclosed17 Aug 2018

Introduced: 17 Aug 2018

CVE-2018-10873  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 spice-protocol to version 0.12.10-1ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-protocol package and not the spice-protocol package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.