Out-of-bounds Write Affecting transfig package, versions <1:3.2.5.e-5ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.43% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-TRANSFIG-267707
  • published25 Sept 2018
  • disclosed30 Aug 2018

Introduced: 30 Aug 2018

CVE-2018-16140  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 transfig to version 1:3.2.5.e-5ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transfig package and not the transfig package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

A buffer underwrite vulnerability in get_line() (read.c) in fig2dev 3.2.7a allows an attacker to write prior to the beginning of the buffer via a crafted .fig file.