Access Restriction Bypass Affecting ubuntu-core-launcher package, versions <1.0.27.1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.49% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-UBUNTUCORELAUNCHER-267435
  • published13 May 2016
  • disclosed13 May 2016

Introduced: 13 May 2016

CVE-2016-1580  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 ubuntu-core-launcher to version 1.0.27.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ubuntu-core-launcher package and not the ubuntu-core-launcher package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The setup_snappy_os_mounts function in the ubuntu-core-launcher package before 1.0.27.1 improperly determines the mount point of bind mounts when using snaps, which might allow remote attackers to obtain sensitive information or gain privileges via a snap with a name starting with "ubuntu-core."