Out-of-Bounds Affecting unzip package, versions <6.0-20ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.84% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-UNZIP-358245
  • published18 Jan 2017
  • disclosed18 Jan 2017

Introduced: 18 Jan 2017

CVE-2016-9844  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 unzip to version 6.0-20ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream unzip package and not the unzip package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Buffer overflow in the zi_short function in zipinfo.c in Info-Zip UnZip 6.0 allows remote attackers to cause a denial of service (crash) via a large compression method value in the central directory file header.