Cross-site Scripting (XSS) The advisory has been revoked - it doesn't affect any version of package viewvc  (opens in a new tab)


Threat Intelligence

EPSS
1.36% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-VIEWVC-564407
  • published3 Apr 2020
  • disclosed3 Apr 2020

Introduced: 3 Apr 2020

CVE-2020-5283  (opens in a new tab)
CWE-79  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:16.04.

NVD Description

Note: Versions mentioned in the description apply only to the upstream viewvc package and not the viewvc package as distributed by Ubuntu.

ViewVC before versions 1.1.28 and 1.2.1 has a XSS vulnerability in CVS show_subdir_lastmod support. The impact of this vulnerability is mitigated by the need for an attacker to have commit privileges to a CVS repository exposed by an otherwise trusted ViewVC instance that also has the show_subdir_lastmod feature enabled. The attack vector involves files with unsafe names (names that, when embedded into an HTML stream, would cause the browser to run unwanted code), which themselves can be challenging to create. This vulnerability is patched in versions 1.2.1 and 1.1.28.