Heap-based Buffer Overflow Affecting vim package, versions <2:7.4.1689-3ubuntu1.5+esm29


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.27% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-VIM-15250572
  • published26 Feb 2026
  • disclosed6 Feb 2026

Introduced: 6 Feb 2026

CVE-2026-25749  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 vim to version 2:7.4.1689-3ubuntu1.5+esm29 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Vim is an open source, command line text editor. Prior to version 9.1.2132, a heap buffer overflow vulnerability exists in Vim's tag file resolution logic when processing the 'helpfile' option. The vulnerability is located in the get_tagfname() function in src/tag.c. When processing help file tags, Vim copies the user-controlled 'helpfile' option value into a fixed-size heap buffer of MAXPATHL + 1 bytes (typically 4097 bytes) using an unsafe STRCPY() operation without any bounds checking. This issue has been patched in version 9.1.2132.

CVSS Base Scores

version 3.1