Out-of-bounds Write Affecting vim package, versions <2:7.4.1689-3ubuntu1.5+esm28


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-VIM-8648738
  • published19 Aug 2025
  • disclosed20 Jan 2025

Introduced: 20 Jan 2025

CVE-2025-24014  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 vim to version 2:7.4.1689-3ubuntu1.5+esm28 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Vim is an open source, command line text editor. A segmentation fault was found in Vim before 9.1.1043. In silent Ex mode (-s -e), Vim typically doesn't show a screen and just operates silently in batch mode. However, it is still possible to trigger the function that handles the scrolling of a gui version of Vim by feeding some binary characters to Vim. The function that handles the scrolling however may be triggering a redraw, which will access the ScreenLines pointer, even so this variable hasn't been allocated (since there is no screen). This vulnerability is fixed in 9.1.1043.

CVSS Base Scores

version 3.1