Use After Free Affecting vlc package, versions <2.2.2-5ubuntu0.16.04.5+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
40.5% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-VLC-360480
  • published22 Jul 2018
  • disclosed11 Jul 2018

Introduced: 11 Jul 2018

CVE-2018-11529  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 vlc to version 2.2.2-5ubuntu0.16.04.5+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vlc package and not the vlc package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

VideoLAN VLC media player 2.2.x is prone to a use after free vulnerability which an attacker can leverage to execute arbitrary code via crafted MKV files. Failed exploit attempts will likely result in denial of service conditions.