Credentials Management Affecting web2py package, versions <2.12.3-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.06% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-WEB2PY-271075
  • published6 Feb 2018
  • disclosed6 Feb 2018

Introduced: 6 Feb 2018

CVE-2016-3952  (opens in a new tab)
CWE-255  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 web2py to version 2.12.3-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream web2py package and not the web2py package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

web2py before 2.14.1, when using the standalone version, allows remote attackers to obtain environment variable values via a direct request to examples/template_examples/beautify. NOTE: this issue can be leveraged by remote attackers to gain administrative access.