Security Features Affecting web2py package, versions <2.12.3-1ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.61% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-WEB2PY-271079
  • published10 Apr 2017
  • disclosed10 Apr 2017

Introduced: 10 Apr 2017

CVE-2016-10321  (opens in a new tab)
CWE-254  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 web2py to version 2.12.3-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream web2py package and not the web2py package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

web2py before 2.14.6 does not properly check if a host is denied before verifying passwords, allowing a remote attacker to perform brute-force attacks.