Use of Hard-coded Credentials Affecting web2py package, versions <2.12.3-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.34% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-WEB2PY-271087
  • published6 Feb 2018
  • disclosed6 Feb 2018

Introduced: 6 Feb 2018

CVE-2016-3953  (opens in a new tab)
CWE-798  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 web2py to version 2.12.3-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream web2py package and not the web2py package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

The sample web application in web2py before 2.14.2 might allow remote attackers to execute arbitrary code via vectors involving use of a hardcoded encryption key when calling the session.connect function.