Directory Traversal Affecting wkhtmltopdf package, versions <0.12.2.4-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.32% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-WKHTMLTOPDF-2982202
  • published19 Aug 2025
  • disclosed15 Aug 2022

Introduced: 15 Aug 2022

CVE-2020-21365  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 wkhtmltopdf to version 0.12.2.4-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wkhtmltopdf package and not the wkhtmltopdf package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Directory traversal vulnerability in wkhtmltopdf through 0.12.5 allows remote attackers to read local files and disclose sensitive information via a crafted html file running with the default configurations.

CVSS Base Scores

version 3.1