Server-Side Request Forgery (SSRF) Affecting xmltooling package, versions <1.5.6-2ubuntu0.3+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.89% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-XMLTOOLING-5751825
  • published1 Jun 2025
  • disclosed25 Jun 2023

Introduced: 25 Jun 2023

CVE-2023-36661  (opens in a new tab)
CWE-918  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 xmltooling to version 1.5.6-2ubuntu0.3+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xmltooling package and not the xmltooling package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

Shibboleth XMLTooling before 3.2.4, as used in OpenSAML and Shibboleth Service Provider, allows SSRF via a crafted KeyInfo element. (This is fixed in, for example, Shibboleth Service Provider 3.4.1.3 on Windows.)

CVSS Base Scores

version 3.1