Directory Traversal Affecting zoneminder package, versions <1.29.0+dfsg-1ubuntu2+esm1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
67.13% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-ZONEMINDER-15737124
  • published21 Mar 2026
  • disclosed26 Apr 2022

Introduced: 26 Apr 2022

CVE-2022-29806  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 zoneminder to version 1.29.0+dfsg-1ubuntu2+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zoneminder package and not the zoneminder package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

CVSS Base Scores

version 3.1