Out-of-bounds Write Affecting zsh package, versions <5.1.1-1ubuntu2.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.53% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1604-ZSH-351960
  • published11 Apr 2018
  • disclosed11 Apr 2018

Introduced: 11 Apr 2018

CVE-2018-1100  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.04 zsh to version 5.1.1-1ubuntu2.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh package and not the zsh package as distributed by Ubuntu. See How to fix? for Ubuntu:16.04 relevant fixed versions and status.

zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in the utils.c:checkmailpath function. A local attacker could exploit this to execute arbitrary code in the context of another user.

CVSS Base Scores

version 3.1