Access Restriction Bypass Affecting bubblewrap package, versions <0.1.5-1~ubuntu16.10.0


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.4% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1610-BUBBLEWRAP-305035
  • published13 Feb 2017
  • disclosed13 Feb 2017

Introduced: 13 Feb 2017

CVE-2016-8659  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.10 bubblewrap to version 0.1.5-1~ubuntu16.10.0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bubblewrap package and not the bubblewrap package as distributed by Ubuntu. See How to fix? for Ubuntu:16.10 relevant fixed versions and status.

Bubblewrap before 0.1.3 sets the PR_SET_DUMPABLE flag, which might allow local users to gain privileges by attaching to the process, as demonstrated by sending commands to a PrivSep socket.