Double Free Affecting fontconfig package, versions <2.11.94-0ubuntu2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.4% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1610-FONTCONFIG-310717
  • published13 Aug 2016
  • disclosed13 Aug 2016

Introduced: 13 Aug 2016

CVE-2016-5384  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.10 fontconfig to version 2.11.94-0ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream fontconfig package and not the fontconfig package as distributed by Ubuntu. See How to fix? for Ubuntu:16.10 relevant fixed versions and status.

fontconfig before 2.12.1 does not validate offsets, which allows local users to trigger arbitrary free calls and consequently conduct double free attacks and execute arbitrary code via a crafted cache file.

CVSS Base Scores

version 3.1