Improper Access Control Affecting libimobiledevice package, versions <1.2.0+dfsg-3~ubuntu1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.99% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1610-LIBIMOBILEDEVICE-317908
  • published13 Jun 2016
  • disclosed13 Jun 2016

Introduced: 13 Jun 2016

CVE-2016-5104  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.10 libimobiledevice to version 1.2.0+dfsg-3~ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libimobiledevice package and not the libimobiledevice package as distributed by Ubuntu. See How to fix? for Ubuntu:16.10 relevant fixed versions and status.

The socket_create function in common/socket.c in libimobiledevice and libusbmuxd allows remote attackers to bypass intended access restrictions and communicate with services on iOS devices by connecting to an IPv4 TCP socket.

CVSS Base Scores

version 3.1