Cross-site Scripting (XSS) Affecting viewvc package, versions <1.1.22-1+deb8u1build0.16.10.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.32% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1610-VIEWVC-313351
  • published15 Mar 2017
  • disclosed15 Mar 2017

Introduced: 15 Mar 2017

CVE-2017-5938  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:16.10 viewvc to version 1.1.22-1+deb8u1build0.16.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream viewvc package and not the viewvc package as distributed by Ubuntu. See How to fix? for Ubuntu:16.10 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in the nav_path function in lib/viewvc.py in ViewVC before 1.0.14 and 1.1.x before 1.1.26 allows remote attackers to inject arbitrary web script or HTML via the nav_data name.