CVE-2017-14176 Affecting bzr package, versions <2.7.0+bzr6619-7ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.24% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-BZR-269933
  • published27 Nov 2017
  • disclosed27 Nov 2017

Introduced: 27 Nov 2017

CVE-2017-14176  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 bzr to version 2.7.0+bzr6619-7ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bzr package and not the bzr package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

Bazaar through 2.7.0, when Subprocess SSH is used, allows remote attackers to execute arbitrary commands via a bzr+ssh URL with an initial dash character in the hostname, a related issue to CVE-2017-9800, CVE-2017-12836, CVE-2017-12976, CVE-2017-16228, CVE-2017-1000116, and CVE-2017-1000117.