CVE-2017-12836 Affecting cvs package, versions <2:1.12.13+real-22ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.64% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-CVS-322723
  • published24 Aug 2017
  • disclosed24 Aug 2017

Introduced: 24 Aug 2017

CVE-2017-12836  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 cvs to version 2:1.12.13+real-22ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cvs package and not the cvs package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

CVS 1.12.x, when configured to use SSH for remote repositories, might allow remote attackers to execute arbitrary code via a repository URL with a crafted hostname, as demonstrated by "-oProxyCommand=id;localhost:/bar."